<!DOCTYPE html>
<html lang="en-US" class="no-js">
<head>
    <meta charset="UTF-8">
    <meta name="viewport" content="width=device-width">
    <link rel="profile" href="http://gmpg.org/xfn/11">
    <link rel="pingback" href="http://batibleki.visitaruba.com/xmlrpc.php">
    <link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/font-awesome/4.4.0/css/font-awesome.min.css">
<!--
            <meta property="og:image" content="http://batibleki.visitaruba.com/wp-content/uploads/2015/10/websitelogo.png"/>
     -->

    <!--[if lt IE 9]>
    <script src="http://batibleki.visitaruba.com/wp-content/themes/twentyfifteen/js/html5.js"></script>
    <![endif]-->
    <script>(function(html){html.className = html.className.replace(/\bno-js\b/,'js')})(document.documentElement);</script>
<title>Bati Bleki Weekly Recap, January 8th, 2017 | Bati Bleki</title>

<!-- All in One SEO Pack 2.3.11.1 by Michael Torbert of Semper Fi Web Design[789,857] -->
<meta name="keywords"  content="bati bleki weekly recap" />

<link rel="canonical" href="http://batibleki.visitaruba.com/bati-bleki-weekly-recap/23156/" />
			<script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','//www.google-analytics.com/analytics.js','ga');

			ga('create', 'UA-2011291-31', 'auto', { 'allowLinker': true } );
			
			ga('send', 'pageview');
			</script>
					<script type="text/javascript">
						function recordOutboundLink(link, category, action) {
														ga('send', 'event', category, action);
														if (link.target == '_blank') return true;
							setTimeout('document.location = "' + link.href + '"', 100);
							return false;
						}
						/* use regular Javascript for this */
						function getAttr(ele, attr) {
							var result = (ele.getAttribute && ele.getAttribute(attr)) || null;
							if (!result) {
								var attrs = ele.attributes;
								var length = attrs.length;
								for (var i = 0; i < length; i++)
									if (attr[i].nodeName === attr) result = attr[i].nodeValue;
							}
							return result;
						}

						function aiosp_addLoadEvent(func) {
							var oldonload = window.onload;
							if (typeof window.onload != 'function') {
								window.onload = func;
							} else {
								window.onload = function () {
									if (oldonload) {
										oldonload();
									}
									func();
								}
							}
						}

						function aiosp_addEvent(element, evnt, funct) {
							if (element.attachEvent)
								return element.attachEvent('on' + evnt, funct);
							else
								return element.addEventListener(evnt, funct, false);
						}

						aiosp_addLoadEvent(function () {
							var links = document.getElementsByTagName('a');
							for (var x = 0; x < links.length; x++) {
								if (typeof links[x] == 'undefined') continue;
								aiosp_addEvent(links[x], 'onclick', function () {
									var mydomain = new RegExp(document.domain, 'i');
									href = getAttr(this, 'href');
									if (href && href.toLowerCase().indexOf('http') === 0 && !mydomain.test(href)) {
										recordOutboundLink(this, 'Outbound Links', href);
									}
								});
							}
						});
					</script>
					<!-- /all in one seo pack -->
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Bati Bleki &raquo; Feed" href="http://batibleki.visitaruba.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Bati Bleki &raquo; Comments Feed" href="http://batibleki.visitaruba.com/comments/feed/" />

    <meta property="og:title" content="Bati Bleki Weekly Recap, January 8th, 2017"/>
    <meta property="og:type" content="article"/>
    <meta property="og:url" content="http://batibleki.visitaruba.com/bati-bleki-weekly-recap/23156/"/>
    <meta property="og:site_name" content="Bati Bleki"/>
    <meta property="og:image" content="http://batibleki.visitaruba.com/wp-content/uploads/2015/11/batibleki.jpg"/>
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/batibleki.visitaruba.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=89873bedab54111af19553ba9ef5e563"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='st-widget-css'  href='http://batibleki.visitaruba.com/wp-content/plugins/share-this/css/style.css?ver=89873bedab54111af19553ba9ef5e563' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css'  href='http://batibleki.visitaruba.com/wp-content/themes/twentyfifteen/style.css?ver=89873bedab54111af19553ba9ef5e563' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-css'  href='http://batibleki.visitaruba.com/wp-content/themes/batibleki2.0/genericons/genericons.css?ver=3.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='twentyfifteen-fonts-css'  href='https://fonts.googleapis.com/css?family=Noto+Sans%3A400italic%2C700italic%2C400%2C700%7CNoto+Serif%3A400italic%2C700italic%2C400%2C700%7CInconsolata%3A400%2C700&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='twentyfifteen-style-css'  href='http://batibleki.visitaruba.com/wp-content/themes/batibleki2.0/style.css?ver=89873bedab54111af19553ba9ef5e563' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='twentyfifteen-ie-css'  href='http://batibleki.visitaruba.com/wp-content/themes/twentyfifteen/css/ie.css?ver=20141010' type='text/css' media='all' />
<![endif]-->
<!--[if lt IE 8]>
<link rel='stylesheet' id='twentyfifteen-ie7-css'  href='http://batibleki.visitaruba.com/wp-content/themes/twentyfifteen/css/ie7.css?ver=20141010' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='adsanity-default-css-css'  href='http://batibleki.visitaruba.com/wp-content/plugins/adsanity/css/widget-default.css?ver=1.0.9.2' type='text/css' media='screen' />
<script type='text/javascript' src='http://batibleki.visitaruba.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://batibleki.visitaruba.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='http://batibleki.visitaruba.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://batibleki.visitaruba.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://batibleki.visitaruba.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='The late Edward Alfred Rodgers, was he the record holder, True or False?!' href='http://batibleki.visitaruba.com/8am-buzz/the-late-edward-alfred-rodgers-was-he-the-record-holder-true-or-false/' />
<link rel='next' title='Local Artist Carmen Mesa is Caribbean Queen for December 2016' href='http://batibleki.visitaruba.com/aruba-tourism-updates/achievements/local-artist-carmen-mesa-is-caribbean-queen-for-december-2016/' />

<link rel='shortlink' href='http://batibleki.visitaruba.com/?p=23156' />
<link rel="alternate" type="application/json+oembed" href="http://batibleki.visitaruba.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fbatibleki.visitaruba.com%2Fbati-bleki-weekly-recap%2F23156%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://batibleki.visitaruba.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fbatibleki.visitaruba.com%2Fbati-bleki-weekly-recap%2F23156%2F&#038;format=xml" />
<script charset="utf-8" type="text/javascript">var switchTo5x=true;</script>
<script charset="utf-8" type="text/javascript" src="http://w.sharethis.com/button/buttons.js"></script>
<script charset="utf-8" type="text/javascript">stLight.options({"publisher":"wp.11c8c0d7-cfdb-45a0-bad6-912bb72571ee","doNotCopy":true,"hashAddressBar":false,"doNotHash":true});var st_type="wordpress4.3.1";</script>
<script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//batibleki.visitaruba.com/?wordfence_logHuman=1&hid=CABAC24B3F4EECE81B1187160EE67CE8');
</script>        <link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/font-awesome/4.4.0/css/font-awesome.min.css">
        <link rel="icon" href="http://batibleki.visitaruba.com/wp-content/uploads/2015/10/cropped-logo-32x32.jpg" sizes="32x32" />
<link rel="icon" href="http://batibleki.visitaruba.com/wp-content/uploads/2015/10/cropped-logo-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="http://batibleki.visitaruba.com/wp-content/uploads/2015/10/cropped-logo-180x180.jpg" />
<meta name="msapplication-TileImage" content="http://batibleki.visitaruba.com/wp-content/uploads/2015/10/cropped-logo-270x270.jpg" />
</head>

<body class="post-template-default single single-post postid-23156 single-format-standard">


<div id="page" class="hfeed site">
    <a class="skip-link screen-reader-text" href="#content">Skip to content</a>
        <div class="bati-bleki-header">
    <header id="masthead" class="site-header" role="banner">
    <div class="column-wrap columns-2">
      <div class="col cols6">
        <div class="site-branding">


                                        <h1 class="site-title"><a href="http://batibleki.visitaruba.com/" rel="home"><img src="/wp-content/uploads/2016/02/batiblekiloghorizontal.png"> </a></h1>
                                            <p class="site-description">Aruba&#039;s Social Column</p>
                                    <button class="secondary-toggle-button"></button>
            </div><!-- .site-branding -->
        </div>

        <div class="col cols6">
                    <div id="widget-area-header" class="widget-area" role="complementary">
                <div id="adsanity-single-2" class="widget-container adsanity-single"><div id="ad-20964" class="ad-728x90 ">
			<a rel="nofollow" href="http://batibleki.visitaruba.com/ads/garage-centraal/" target="_blank"><img width="728" height="90" src="http://batibleki.visitaruba.com/wp-content/uploads/2016/02/garage_central.jpg" class="attachment-full size-full wp-post-image" alt="" srcset="http://batibleki.visitaruba.com/wp-content/uploads/2016/02/garage_central.jpg 728w, http://batibleki.visitaruba.com/wp-content/uploads/2016/02/garage_central-500x62.jpg 500w" sizes="(max-width: 728px) 100vw, 728px" /></a>
	</div></div>            </div><!-- .widget-area -->
        </div>
            </div>
        </header><!-- .site-header -->



            <nav id="site-navigation" class="main-navigation" role="navigation">
            <div class="menu-main-menu-container"><ul id="menu-main-menu" class="nav-menu"><li id="menu-item-19860" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-19860"><a href="http://batibleki.visitaruba.com/">Bati Bleki Weekly Recap</a></li>
<li id="menu-item-19869" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19869"><a href="http://batibleki.visitaruba.com/category/8am-buzz/">8am buzz</a></li>
<li id="menu-item-12527" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12527"><a href="http://batibleki.visitaruba.com/about/">About Rona Coster</a></li>
<li id="menu-item-12525" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12525"><a href="http://batibleki.visitaruba.com/category/aruba-tourism-updates/">Tourism Updates</a></li>
<li id="menu-item-20963" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-20963"><a target="_blank" href="https://www.facebook.com/BatiBlekiBuzz/"><i class="fa fa-facebook-official"></i></a></li>
<li class="menu-item menu-item-search"><button class="search-toggle genericon"><span class="screen-reader-text">Search</span></button><div class="form-wrapper"><form method="get" class="menu-search-form" action="http://batibleki.visitaruba.com/"><input class="text_input" type="text" placeholder="search..." value="" name="s" id="s" /><button type="submit" class="search-submit genericon"><span class="screen-reader-text">Search</span></button></form></div></li></ul></div>        </nav><!-- .main-navigation -->
        </div>
    <div id="sidebar" class="sidebar ">



            <div id="" class="">


        
                    <div id="widget-area" class="widget-area" role="complementary">
                <aside id="adsanity-group-4" class="widget adsanity-group"><div id="ad-22680" class="ad-88x31 column-1">
			<a rel="nofollow" href="http://batibleki.visitaruba.com/ads/22680/" target="_blank"><img width="240" height="400" src="http://batibleki.visitaruba.com/wp-content/uploads/2016/11/GC_awor240x400.jpg" class="attachment-full size-full wp-post-image" alt="" /></a>
	</div><div id="ad-22783" class="ad-88x31 column-2">
			<a rel="nofollow" href="http://batibleki.visitaruba.com/ads/22783/"><img width="300" height="250" src="http://batibleki.visitaruba.com/wp-content/uploads/2016/11/bati-bleki-2.png" class="attachment-full size-full wp-post-image" alt="" /></a>
	</div><div id="ad-22785" class="ad-88x31 column-3">
			<a rel="nofollow" href="http://batibleki.visitaruba.com/ads/22785/"><img width="300" height="250" src="http://batibleki.visitaruba.com/wp-content/uploads/2016/11/bati-bleki-2.png" class="attachment-full size-full wp-post-image" alt="" /></a>
	</div><div id="ad-21293" class="ad-240x400 column-4">
			<a rel="nofollow" href="http://batibleki.visitaruba.com/ads/elements-restaurant/" target="_blank"><img width="240" height="400" src="http://batibleki.visitaruba.com/wp-content/uploads/2016/03/16076-ElementsGeneral-BatiBleki-240x400-Option2-Final.jpg" class="attachment-full size-full wp-post-image" alt="" /></a>
	</div><div class="clear clearfix clearboth"></div></aside>            </div><!-- .widget-area -->
        
    </div><!-- .secondary -->

    </div><!-- .sidebar -->




    <div id="content" class="site-content">

    <div id="primary" class="content-area">
        <main id="main" class="site-main" role="main">

        
<article id="post-23156" class="post-23156 post type-post status-publish format-standard hentry category-bati-bleki-weekly-recap">


    
    <header class="entry-header">
        <h1 class="entry-title">Bati Bleki Weekly Recap, January 8th, 2017</h1>    </header><!-- .entry-header -->

    <div class="entry-content">
  <p>Ron Wever – A man with a biting sense of humor, left us</p>
<p style="font-style: inherit; font-weight: inherit;">My original caricature for the Bati Bleki column in the Diario was sketched by caricaturist Ron Wever. The column appeared in the Diario, so naturally I asked Ron to do the header. He delivered, and I did not like it. It was not complimentary. He drew me with sparkling eyes, and a large nose, as if I just landed a colossal scoop. I didn’t like the drawing. I wanted to be cute, and he delivered a character study, thus his header was never used.</p>
<p style="font-style: inherit; font-weight: inherit;">Ron came back to Aruba, having graduated some fancy art school in the Netherlands. Freshly married he went to work as a graphic-designer at the NEWS, the English newspaper and later at Corant Corant, a politically-tainted daily, where the owners hired him as a layout man. Noticing his ability to draw Stanley Arends asked Ron to come up with a caricature. The big news that day was the introduction of the K9 unit, and the drug sniffing dogs. Ron’s caricature featured a Customs officer restraining a K9 ‘officer’ barking furiously at the Minister of Justice, implying the then-minister had perhaps a few shady deals to hide.</p>
<p style="font-style: inherit; font-weight: inherit;">That morning, Aruba was introduced to the caustic, sarcastic and stinging wit of the layout man turned cartoonist, and he never disappointed. He would read the newspapers daily and come up with a fresh, irreverent, razor-sharp observation. As he moved to Diario, Aruba’s largest daily, he got a green light to express himself freely. And when he was ‘brain-dead,’ the editors helped point him in the right direction, moving from the issues on page 1 to page 2 or 3, in search of a juicy shortcoming, a zinging observation. His most frequent subject was politician Nel Oduber whom he usually depicted with an extra special long tongue.</p>
<p style="font-style: inherit; font-weight: inherit;">I reminisced with a fellow newspaper man yesterday. We thought Ron’s funniest cartoon to date was that of the PPA leader climbing over the cemetery fence, in search of PPA voters, alas, he was late, they were all 6 feel under, and his party beat the dust at elections. Ron always made us laugh.</p>
<p style="font-style: inherit; font-weight: inherit;">While somehow blood related to the MEP political party, he lynched its politicians mercilessly; he was almost equally unkind to AVP, ridiculing members of the green party incessantly; he was an equal opportunity executioner, across party lines.</p>
<p style="font-style: inherit; font-weight: inherit;">Ron passed away after a bout with cancer on the last day of the year, and asked for a short no-frill memorial. He is survived by two lovely daughters, and an extended family, on both ends of the political spectrum. Alas, page 2 of the Diario will never look the same without him.</p>
<p style="font-style: inherit; font-weight: inherit;">On a conformist island his blunt and irreverent commentary on issues and personalities will be greatly missed. He was a gate-keeper, determined to keep the political constellations honest!</p>
<h1>The Craze of Crazy First Names on the Island</h1>
<p style="font-style: inherit; font-weight: inherit;">I had a signature massage this week at the Spa of the Ritz Carlton by a therapist named Elix.</p>
<p style="font-style: inherit; font-weight: inherit;">Was your father in a rush, I asked when he registered you at Censo? Did he just drop the F, in his haste? No, replied Elix, my name is a cross between grandma Elsie and grandpa Alex. I hear they were going to call me Elixier and I am grateful they picked the short version.</p>
<p style="font-style: inherit; font-weight: inherit;">So now you know how they have been naming kids in Aruba in the past two or three decades. Let’s say Glenda and Eric had a kid, they would name him Glendrick, of course. Why the added K? Why not?!</p>
<p style="font-style: inherit; font-weight: inherit;">Or take for instance the real life example of Anthony &amp; Jean. Yes, there is a kid named Antheajean, walking and talking among us.</p>
<p style="font-style: inherit; font-weight: inherit;">Charles &amp; Jane? That’s easy. They named their daughter Charjaine. And why added I? Why not!</p>
<p style="font-style: inherit; font-weight: inherit;">Over the past few weeks we have been going through obituaries and social press releases, looking for crazy first names. I hope you all forgive me for the infringement of privacy, but the names are incredibly complex and incomprehensible in seven languages. How do local school teacher memorize these monsters? Your guess is as good as mine.</p>
<p style="font-style: inherit; font-weight: inherit;">Apparently our society values so-called originality above all, creating meaningless, phonetically complex, impossible to spell and difficult to memorize names, in total disregard of the baby’s considerable difficulties, later in life, to explain his first name, let alone write it.</p>
<p style="font-style: inherit; font-weight: inherit;">We realized that families favor certain sounds and letters, names that rhyme, the more complex the better. How about cousins Eldrick, Derrick, Divan, Davin and Darrell? Easy?!</p>
<p style="font-style: inherit; font-weight: inherit;">Let’s try something more complex, cousins Jarvis, Jahrvin, Jahrsienne and Jahlyn? Are you comfortable with that?</p>
<p style="font-style: inherit; font-weight: inherit;">How about Qushendre, Qusheyden and Qushaylee?</p>
<p style="font-style: inherit; font-weight: inherit;">We haven’t invented any of this. Most popular letters are G, J and S; least popular letters are H, I, P, U, V and W, which means no Henry, no Irene, no Peter, no Ursula, and no Vivian!</p>
<p style="font-style: inherit; font-weight: inherit;">Not a single good old bible-inspired name.</p>
<p style="font-style: inherit; font-weight: inherit;">Anyway, put on your seat belt, we’re going on a linguistic adventure; the following is Aruba’s modern baby name dictionary, in alphabetical order:</p>
<p style="font-style: inherit; font-weight: inherit;">Akyrah, Aishwayra, Amish, Ar-Xanne, Anwynn, Alghian, Artoir and ArlexDavid</p>
<p style="font-style: inherit; font-weight: inherit;">Braylon.</p>
<p style="font-style: inherit; font-weight: inherit;">Charmainy, Charlaine, Chedsel, Cyanne, Chesron, Clyphan, and Cee-Cyon.</p>
<p style="font-style: inherit; font-weight: inherit;">Dainalys, Devaughn, Dylaisha, Danisha, Djessenia, Darylyne, D’Jeandrick, D’Lainey, Dashenka and Darshawn.</p>
<p style="font-style: inherit; font-weight: inherit;">Eirian</p>
<p style="font-style: inherit; font-weight: inherit;">Frangina and Franslin</p>
<p style="font-style: inherit; font-weight: inherit;">Gilliandra, Gringer, Giannely, Gixelangela, Giovangelo, Gesinio, Ghiamylane, Ghiannon, Ghialmar, Ghizienne, Ghaiyzion and Ghizlainy</p>
<p style="font-style: inherit; font-weight: inherit;">Joyrick, Jesviance, Jurienne, Jayly-Ann, Jeliane, Jhanirha, Jasory, Jasmeline, Jasorick, Jayli, Jion, Jamyliane, Ju-Ailly, Jermar, Josey, Jurandrick, Jeanelys, Jeanayla, Jo-Annie, Jayquin, Johairo, Jesselaine, Jennelaine, Jescaraine, Jenneviene, Jahlyone, Jdylienne,  Jean-Te, Jarredson, Juandro, Jayron, Jeliandra,Jayven, Jirzion and Julirey.</p>
<p style="font-style: inherit; font-weight: inherit;">Kenrick, Kathlene, Kadisha, Kymani, Kaynar and Keyshawn.</p>
<p style="font-style: inherit; font-weight: inherit;">Li-Anne, Lifrendly and Lydienne.</p>
<p style="font-style: inherit; font-weight: inherit;">Minielsy, Marilushka and Makaylee.</p>
<p style="font-style: inherit; font-weight: inherit;">Nayree, Najean, Nashmine and Nay-Amy.</p>
<p style="font-style: inherit; font-weight: inherit;">Osneil, Ottmare</p>
<p style="font-style: inherit; font-weight: inherit;">Quishone, Quilion, Quilla and Q-Jay.</p>
<p style="font-style: inherit; font-weight: inherit;">Randerly, Rozeal, Raidan and Richinell.</p>
<p style="font-style: inherit; font-weight: inherit;">Shaquir, Shekainah,  Shandjeny, Shakion, Shavenk, Saina, Shamiro, Shamark, Sharetty, Shedmun<u>, </u>Shereline, Shanuska, Shrenda, Shudion, Shaqceli, Shakely, Shay-Mery and Seanwyn.</p>
<p style="font-style: inherit; font-weight: inherit;">Tyrese, Tharlee, Tatiaa and Tshawnee</p>
<p style="font-style: inherit; font-weight: inherit;">Xavion</p>
<p style="font-style: inherit; font-weight: inherit;">Yon and Yshandro.</p>
<p style="font-style: inherit; font-weight: inherit;">Zixienne, Zul-Anne, Zyren, Zaion, Zinayli, Zayn and Zhyon.<span style="font-style: inherit; font-weight: inherit;"> </span></p>
<h1>What’s in a name II</h1>
<p style="font-style: inherit; font-weight: inherit;">There was a lot of traffic on my FB yesterday after the piece I did on giving kids in Aruba names which are difficult to spell or pronounce, in the name of originality.</p>
<p style="font-style: inherit; font-weight: inherit;">The piece was titled “What’s in A Name,” and after all the exchanges on my page, my educated friend Myriam Tonk-Croes, continue to ask me so… “What’s in a Name?”</p>
<p style="font-style: inherit; font-weight: inherit;">Here is what I know, and Patrick Brown already summed it up: “It’s a proven fact that these strange names will hamper the bearer in all sorts of ways later in life, be it finding a job or finding a partner. Putting your child at a disadvantage in life by giving him or her, such a very “unique” name is regrettable.”</p>
<p style="font-style: inherit; font-weight: inherit;">And I will add to his statement that naming a child is like giving him a road map. Naming him after an accomplished departed elder honors the family member and gives the child a role model to follow, a direction in life.</p>
<p style="font-style: inherit; font-weight: inherit;">Naming a child after a national hero, a member of the royal family, or a righteous biblical personality sets the bar high, sending the newborn a signal that expectations were set, and he has a lifetime to meet them.</p>
<p style="font-style: inherit; font-weight: inherit;">And that’s how people grow into their names, to become useful members of our society, motivated to honor the greatness that their name implies.</p>
<p style="font-style: inherit; font-weight: inherit;">When you name a child respectfully and meaningfully, you are setting him up for a smooth co-existence, with his/her teachers and even the tax authority – they will never be asked to spell or pronounce their names, the margin of error is minimal.</p>
<p style="font-style: inherit; font-weight: inherit;">Names may also hint at a family’s country of origin, Oliver would be British, Sean Irish, Antonio Italian and Kwanzaa, African. But with globalization, you can never tell. We often borrow named across borders. (Barak mean lightning, in Hebrew)</p>
<p style="font-style: inherit; font-weight: inherit;">To conclude the naming saga, I remember my son had a co-worker at the Ritz Carlton by the name of Esmaili. I asked. He explained. His Dominican mother decided to call her baby Smiley, and Esmaili is what she heard, phonetically. I also found the name Usnavy, which is popular in the Dominican Republic. Having seen US Navy, scribbled across the bow of a ship in the harbor, Usnavy became a proper first name.</p>
<p style="font-style: inherit; font-weight: inherit;">So what’s in a name? Your road map for life!</p>
<p><strong>The late Edward Alfred Rodgers, was he the record holder, True or False?!</strong></p>
<p>So before I delve into politics and relationships in 2017, I must acknowledge the quiet oversize contributions of Edward Alfred Rodgers, who passed away in December.</p>
<p>Charlie’s Bar posted the following announcement mid-month: One of the most famous characters of San Nicolas: Edward Alfred Rodgers, Alhambra’s Genie. Also a Goodwill Ambassador of Aruba<em>,</em> has passed away.</p>
<p>I decided to add a bit to that telegram, after all it is rumored that this man was the holder of the Guinness Book of World Records for most hands shaken, in a lifetime.</p>
<p>True, or False is the question.</p>
<p>A native of San Nicholas, Rodgers started working at Divi Divi Beach Resort in 1974, as the nighttime maintenance man. His job consisted of walking up and down the poorly lit paths with a giant flashlight, showing hotel guests the shortest way from the bar to their rooms. You have to imagine the hotel at the time, a few dozen casitas sprawled out on a dark beach, then you meet the grinning giant, Rodgers and the flashlight, naturally, he immediately became a beacon of friendliness and orientation, a great favorite among the hotel’s repeat guests.</p>
<p>Mid 80s Rodgers was transferred to the Alhambra Casino as the doorman, and befitting the Moorish design theme of the casino he was dressed in a long green velvet vest, his chest festooned with gold buttons, he legs planted in a pair of roomy jodhpurs, tucked into knee-high black boots, topped by a gold trimmed turban. He earned his nickname the Alhambra Genie, that way. As he grew into his job, his title was appropriately changed to Goodwill Ambassador, which he was.</p>
<p>Rodgers who lived with his mother, in San Nicholas, was never married, but enjoyed many friends and acquaintances when he retired due to illness in 2009; he traded the Alhambra Casino in Oranjestad for Charlie’s Bar in St Nicholas, and continued to shake hands and socialize until he passed away this December.</p>
<p>So did he really shake a record of hands in his lifetime? I believe he did. The title was never officially approved by the book organization, but I thought he deserved it, and as the marketing director of that casino, I allowed myself the freedom to say so. You must agree that if he stood at the Alhambra’s entrance every night greeting players in and out the door, with a firm handshake, that would amount to millions of people over THIRTY FIVE years.</p>
<p class="no-break"><span class='st_facebook_large' st_title='Bati Bleki Weekly Recap, January 8th, 2017' st_url='http://batibleki.visitaruba.com/bati-bleki-weekly-recap/23156/'></span></p>  </div>
<!-- .entry-content -->

    
    <footer class="entry-footer">
        <span class="posted-on"><span class="screen-reader-text">Posted on </span><a href="http://batibleki.visitaruba.com/bati-bleki-weekly-recap/23156/" rel="bookmark"><time class="entry-date published" datetime="2017-01-08T08:35:33+00:00">January 8, 2017</time><time class="updated" datetime="2017-01-08T08:36:49+00:00">January 8, 2017</time></a></span><span class="byline"><span class="author vcard"><span class="screen-reader-text">Author </span><a class="url fn n" href="http://batibleki.visitaruba.com/author/rona/">Rona</a></span></span><span class="cat-links"><span class="screen-reader-text">Categories </span><a href="http://batibleki.visitaruba.com/category/bati-bleki-weekly-recap/" rel="category tag">Bati Bleki weekly recap</a></span>            </footer><!-- .entry-footer -->

</article><!-- #post-## -->

             <div class="after_post">
                            <div id="primary-sidebar " class="primary-sidebar widget-area wrapper" role="complementary">
            <div id="adsanity-single-3" class="widget-container adsanity-single"><div id="ad-22668" class="ad-728x90 ">
			<a rel="nofollow" href="http://batibleki.visitaruba.com/ads/optica-moderna/"><img width="694" height="142" src="http://batibleki.visitaruba.com/wp-content/uploads/2016/10/newspaper-ad.jpg" class="attachment-full size-full wp-post-image" alt="" srcset="http://batibleki.visitaruba.com/wp-content/uploads/2016/10/newspaper-ad.jpg 694w, http://batibleki.visitaruba.com/wp-content/uploads/2016/10/newspaper-ad-500x102.jpg 500w" sizes="(max-width: 694px) 100vw, 694px" /></a>
	</div></div>                </div><!-- #primary-sidebar -->
            </div>
            
	<nav class="navigation post-navigation" role="navigation">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="http://batibleki.visitaruba.com/bati-bleki-weekly-recap/bati-bleki-weekly-recap-december-11th-2016/" rel="prev"><span class="meta-nav" aria-hidden="true">Previous</span> <span class="screen-reader-text">Previous post:</span> <span class="post-title">Bati Bleki Weekly Recap, December 11th, 2016</span></a></div></div>
	</nav>

        </main><!-- .site-main -->
    </div><!-- .content-area -->


    </div><!-- .site-content -->

    <div id="sidebar2" class="sidebar">
    <div id="" class="">

                    <div id="widget-area-right" class="widget-area" role="complementary">
                <aside id="adsanity-group-3" class="widget adsanity-group"><div id="ad-22759" class="ad-240x400 column-1">
			<a rel="nofollow" href="http://batibleki.visitaruba.com/ads/banco-di-caribe/" target="_blank"><img width="240" height="400" src="http://batibleki.visitaruba.com/wp-content/uploads/2016/11/GC_7v240x400.jpg" class="attachment-full size-full wp-post-image" alt="" /></a>
	</div><div id="ad-21309" class="ad-240x400 column-2">
			<a rel="nofollow" href="http://batibleki.visitaruba.com/ads/stimami/" target="_blank"><img width="240" height="400" src="http://batibleki.visitaruba.com/wp-content/uploads/2016/03/BatiBleki-WebAd.jpg" class="attachment-full size-full wp-post-image" alt="" /></a>
	</div><div id="ad-22682" class="ad-88x31 column-3">
			<a rel="nofollow" href="http://batibleki.visitaruba.com/ads/22682/" target="_blank"><img width="300" height="250" src="http://batibleki.visitaruba.com/wp-content/uploads/2016/11/GC_awor300x250.jpg" class="attachment-full size-full wp-post-image" alt="" /></a>
	</div><div class="clear clearfix clearboth"></div></aside>            </div><!-- .widget-area -->
        
    </div><!-- .secondary -->

    </div><!-- .sidebar -->


    <footer id="colophon" class="site-footer" role="contentinfo">
        <div class="site-info">
                        <a href="//www.visitaruba.com/"><img src="/wp-content/uploads/2016/02/visitAruba.png"><br>VisitAruba.com Member Site</a>
            <p class="designed">Design & Hosting by <a href="http://www.caribmedia.com/" target="_blank">CaribMedia</a></p>

        </div><!-- .site-info -->
    </footer><!-- .site-footer -->

</div><!-- .site -->
<div class="back-top-button"></div>


<script type='text/javascript' src='http://batibleki.visitaruba.com/wp-content/themes/batibleki2.0/js/custom.js?ver=1.0.0'></script>
<script type='text/javascript' src='http://batibleki.visitaruba.com/wp-content/themes/batibleki2.0/js/column_script.js?ver=1.0.0'></script>
<script type='text/javascript' src='http://batibleki.visitaruba.com/wp-content/themes/twentyfifteen/js/skip-link-focus-fix.js?ver=20141010'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var screenReaderText = {"expand":"<span class=\"screen-reader-text\">expand child menu<\/span>","collapse":"<span class=\"screen-reader-text\">collapse child menu<\/span>"};
/* ]]> */
</script>
<script type='text/javascript' src='http://batibleki.visitaruba.com/wp-content/themes/twentyfifteen/js/functions.js?ver=20150330'></script>
<script type='text/javascript' src='http://batibleki.visitaruba.com/wp-includes/js/wp-embed.min.js?ver=89873bedab54111af19553ba9ef5e563'></script>

</body>
</html>
